CentOS

CentOS 6 и php 5.2.17

В дистрибутиве CentOS 6 изначально присутствует php версии 5.3. Это не всегда хорошо, потому как многие программы работают с этой ветко криво. Например UmiCMS. Вот и возникает парадоксальная ситуация, связанная со снижением версии php например до  5.2.17.

Одним из вариантов решения данного вопроса является использование репозитария atomic. Для его установки используем следующие команды:

wget http://www.atomicorp.com/installers/atomic
sh atomic

Далее удаляем установленный php.

Обновляем PHP с 5.1.x до 5.2.x на CentOS 5.3

 В стандартной поставке CentOS 5.3 включен php версии 5.1.6, который, мягко говоря, ну совсем не новый. К нашему счастью у CentOS есть тестовый репозитарий. Его нужно включить и обновить php.

Создаем файлик:

touch /etc/yum.repos.d/CentOS-Testing.repo 

открываем его в нашем любимом текстовом редакторе и добавляем туда следующие строки:

Включаем EPEL (Extra Packages for Enterprise Linux) репозитарий для Red Hat Enterprise Linux / CentOS Linux.

Изменился адрес репозитария:
http://fedoraproject.org/wiki/EPEL/FAQ

К своему стыду, признаюсь, что о замечательном репозитарии  EPEL я узнал совсем недавно. Немного поковырялся с ним и решил написать небольшую заметку о нем, и о том, как его быстро и безболезненно поставить.

Итак. EPEL - (Extra Packages for Enterprise Linux) является является репозитарием, основанным сообществом Fedora project  как хранилище высококачественных дополнительных пакетов, которые дополняют как они пишут "Fedora based" Red Hat Enterprise Linux (RHEL).  Конечно же, если этот репозитарий подходит для RHEL, значит он может использоваться и для RHEL клонов, таких как, например, CentOS или Scientific Linux.

RSS-материал